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Indicates a premier feature of DataTrac Software

Indicates a reminder

Indicates a warning

SKC Limited Warranty and Return Policy
SKC products are subject to the SKC Limited Warranty and Return Policy, which provides SKC’s sole
liability and the buyer’s exclusive remedy. To view the complete SKC Limited Warranty and Return
Policy, go to http://www.skcinc.com/warranty.
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Introduction

Introduction
DataTrac Software for Leland Legacy
Features
• Program a sampling operation from a PC
• Calibrate pump flow
• Display the operating state including flow rate, temperature, atmospheric
pressure, run time, and battery status of the connected pump
• Create and save a sampling program without a pump connected to the PC
• Program up to 26 sampling sequences, each at diﬀerent flow rates, if desired
• Download pump run time data and history to your PC
• Document sampling history using the sample setup feature
• Print a history file containing pump run time data
• Print a worker exposure profile containing run time data and pump history
• Document date of pump calibration

DataTrac System Requirements
•
•
•
•

Hard drive with a minimum of 20 MB free disc space
Available USB port for use with SKC USB DataTrac adapter cable
Mouse
Microsoft® Windows® 7 or higher

DataTrac Components
• DataTrac Software and instructions via free download on website
• DataTrac adapter cable
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DataTrac Setup
Installing DataTrac Software
Installation of New Software
1. Close all applications.
2.

Go to www.skcinc.com/catalog/datatrac/DataTracLeland_license.html.
See Download DataTracLeland for the Leland Legacy for instructions on
downloading and installing DataTrac on your PC.
If installation is unsuccessful, an error box will display indicating that installation
was not successful and that the user should perform the installation procedure again.
A shortcut to Legacy.exe will be installed automatically on
the PC desktop.

If changes to settings are desired after installation, perform Steps 1 through 4 below.
The IS Program Maintenance window will display. Select Modify to change settings.
Installation of Software Update (previous version exists on PC)
1. Close all applications.
2.

Go to www.skcinc.com/catalog/datatrac/DataTracLeland_license.html.
See Download DataTracLeland for the Leland Legacy for instructions on
downloading and installing DataTrac on your PC.

3.

The IS Welcome window will display. Click Next.

4.

The IS Program Maintenance window will display. Three options will appear:
• Modify - used to change settings after installation
• Repair - used to update previously installed software
• Remove - used to remove the previously installed version of the software
from the hard drive (SKC recommended).
a. Click Remove.
b. Click Next.
c. The IS Remove the Program window will display.
d. Click Remove.
e. The IS Removing the Program window will display.
f. The IS Wizard Completed window will display, indicating successful
removal of the existing software.
g. Click Finish to exit the IS Wizard.
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5.

Follow instructions for Installation of New Software.
Complete DataTrac Software features are only available when an active sample
pump is connected to the PC (see Connecting the Pump to a PC). The SKC
DataTrac Pump Manager window may be accessed without a pump connected
to the PC; however, only limited features will be available (see Connecting the
Pump to a PC, Connection Error Box, Figure 2B on page 5).
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Connecting the Pump to a PC (Figure 1)
USB port on PC: Use the supplied adapter cable to connect the pump to the PC.

Pump
interface port
W
FLO

L / mins

Adapter
cable

Figure 1. Hardware Setup

First Time Connection
1.

2.
3.
4.
5.

Connect the pump to a PC using the DataTrac adapter cable.
a. If a Found New Hardware Wizard window displays during connection,
follow this procedure:
i. Ensure the wizard wants to install software for “USB Serial Port.”
1. If the wizard wants to install any other software, cancel the wizard,
and connect the adapter cable to a different USB port.
ii. Select Install the software automatically (Recommended).
iii. Click Next.
iv. The installing USB Serial Port window will display. Installation may
take several minutes. Do not press any keys during installation.
v. The Completing the Found New Hardware Wizard window will
display, indicating a successful installation.
vi. Click Finish to close the wizard.
Activate the pump LCD by pressing any button on the pump keypad.
Launch DataTrac Software on the PC by double-clicking the
Leland Legacy shortcut icon on the PC desktop.
The Leland Legacy Connection window will display (Figure 2).
a. Click Connect to Pump
If connection is successful, the Leland Legacy Connection window will display a
shaking hands icon (Figure 2A). Proceed to Step 6. If connection is unsuccessful,
an error window will display (see box and Figure 2B on page 5).

Figure 2. Connection
Window

Figure 2A. Successful
Pump-PC Communication
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Successive Connections
1.
2.
3.
4.
5.

Connect the pump to a PC using the DataTrac adapter cable.
Activate the pump LCD by pressing any button on the pump keypad.
Launch DataTrac Software on the PC by double-clicking the Leland Legacy
shortcut icon on the PC desktop.
The Leland Legacy connection window will display (Figure 2).
a. Click Connect to Pump.
The Leland Legacy Connection window will display a shaking hands icon
indicating a successful connection (Figure 2A). Proceed to Step 6.

Connection Error Box
If an error box displays during connection (Figure 2B), follow this procedure:
a. Ensure pump LCD is activated. See Step 2 on page 4.
b. Check cable connections and click Retry. If the
error box displays again, go to Step c.
c. Ensure the COM ports for the adapter cable
are numbered between 1 and 9. See changing
the COM Port box below.
Another option in the error box is Ignore. Clicking
Ignore opens the SKC DataTrac Pump Manager
window but only allows limited access to software
features.

Figure 2B. Connection
Error Box

Changing the COM Port
To change the COM port:
1. Ensure DataTrac adapter cable is connected to a USB port.
2. Click Start menu.
3. Right click on My Computer.
4. Select Manage.
5. Select Device Manager.
6. Expand the Ports (COM & LPT) menu.
7. Double-click to select USB Serial Port
(COM10 or similar).
8. Select Port Settings.
9. Click on Advanced.
10. Select a COM port between 5 and 9 from
the COM Port Number dropdown menu.
11. Click OK to close.
12. Follow instructions for Connecting the
Pump to a PC (see page 4).
COM Port Window
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6.

7.

If the date and time settings
on the PC and pump differ by
a day or more than 5 minutes,
respectively, a Time Discrepancy
Alert window will display
(Figure 3).
a. Reconcile the date
and/or time.
b. Click OK.
DataTrac Software will load
and display the SKC DataTrac
Pump Manager window
(Figure 4).

FLOW

L / mins

LelandLegacy

Figure 3. Time Discrepancy Alert Window

Recommended for first time users: Connect a Leland Legacy pump
to your PC and explore the features of DataTrac through the Real Time
Monitor (see page 8).
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SKC DataTrac Pump Manager
The SKC DataTrac Pump Manager window (Figure 4) is the first window that opens
in DataTrac. All windows are accessible from this main window.

Figure 4. SKC DataTrac Pump Manager Window

SKC DataTrac Pump Manager Menus
File Menu
Exit...............................exits the program and returns to Windows
View Menu
Pump Scheduler ........opens the SKC Pump Scheduler window
STEL/Timed Run .......opens the STEL/Timed Run window
Sample Sheet ..............opens the Sample Sheet Setup window
Report .........................loads a report file previously saved to a PC
Pump History ............opens the SKC Pump History window
Archive History .........loads a history file previously saved to a PC
Calibration Info .........opens the Calibration Info window
Real Time Monitor ....opens the SKC Real Time Monitor window
Tools Menu
Set Date/Time.............opens the Set Date/Time for Pump window
Temperature and Pressure
Calibration..................opens Temperature and Barometric Calibration
Help Menu
About ..........................displays the PC and pump software version numbers,
pump serial number, date of last full calibration,
language, and information about downloading the
latest version of DataTrac
On-line Manual .........displays latest DataTrac Software Operating
Instructions (Form 40085) in PDF format. To
download, go to www.skcinc.com/DataTracLeland.
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SKC Real Time Monitor
The SKC Real Time Monitor window (Figure 5) directly controls the pump, allows
calibration of flow rate, displays a real time readout of pump operations, and
displays the connected pump‘s serial number.
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Figure 5. Real Time Monitor Window

A.
B.
C.
D.
E.
F.
G.
H.
I.

Real Time Monitor Display (page 9)
Flow Calibrate Buttons (page 10)
Temperature Display (page 12)
Pressure Display (page 13)
Pump Controls Buttons (page 13)
Units Selection Buttons (page 14)
Fault Options (page 14)
Battery Selection Buttons (page 10)
Comm Checking Buttons (page 11)

Real Time Monitor Menus
File Menu
Exit ............................ returns to the previous screen
Tools Menu
Clear Schedule ........ clears the programmed pump schedule from the
pump
Clear STEL/
Timed Run ............ clears programmed timed run from the pump
Clear History ........... clears the pump history
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Pump Real Time Monitor Display
The Real Time Monitor display (Figure 6) shows the operating status of the connected
pump.
Pump Status
Cell Readout
Operating State of the Pump
Run ............................pump in run mode
Hold ..........................pump in hold mode
Fault (Run) ...............pump in flow fault status while
running
Fault (Hold)..............pump in flow fault status and
hold mode
Prog (Hold) ..............pump in hold mode while
running a program
Prog (Run) ................pump in flow mode while
Figure 6. Pump Real
running a program
Time Monitor Display
Prog (Sleep) ..............pump in sleep mode while
running a program
Reset ..........................run time data has been zeroed
Sleep ..........................pump in sleep mode
User Setup ................pump user interface accessed and user adjusting
pump
Pre-Cal Flow ............single-point calibration mode; first calibration
average, date, and time
Post-Cal Flow ...........single-point calibration mode; final calibration
average, date, and time
Timed Run................pump running a preset sampling time (ST)
Low Bat .....................battery depleted
Flow Adjust ..............pump flow rate or flow correction being adjusted by
user
Flow Cell ..............current pump flow rate in L/min
Volume Cell.........total volume of air pumped since reset
Run time Cell ......total run time of pump since reset
Total Time Cell ...total run time of pump since factory calibration
Battery Cell .........graphically displays battery life. The battery life is indicated by a
colored bar with low (-) charge indicated on the left side and full
(+) charge indicated on the right side. A long colored bar (closer to
the + end) represents a battery near a full charge. A short colored
bar (closer to the - end) represents a battery near depletion.
Data in the Pump Real Time Monitor display cells is updated every 5 seconds.
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Battery Selection Buttons
The Battery Selection Buttons (Figure 7) allow the
user to select the battery that is installed in the
sample pump. Check the label on the battery pack,
and then click the button next to the appropriate
battery Part No. Selecting the proper battery ensures
that the pump indicates accurate battery status.
Figure 7. Battery
Selection Buttons

Flow Calibrate Buttons
The Flow Calibrate buttons (Figure 8) are used to
apply a correction to the pump flow rate during
calibration to a primary standard

Controls
Function
................................increases correction of pump
flow rate
................................decreases correction of pump
flow rate
Figure 8. Flow Calibrate
Reset..........................zeroes the value in the Approx
Correction cell
Comm Checking .....turns the communication
checking function on or oﬀ. This feature allows the user to
unplug a pump and plug in another pump without causing a
communication error.
Adjusting the Approximate Flow Correction
The Leland Legacy pump should be calibrated before each sample run.
1.

Click the Reset button to reset the correction value to 0.00 L/min.
Changing the pump flow setting will also reset the correction value to
0.00 L/min.

2.

Turn on the pump and connect the inlet port of the pump to a primary standard
calibrator. Read the flow displayed on the calibrator.

3.

Click on the  or  buttons in the Flow Calibrate window until the calibrator
displays the desired flow rate.
When adjusting the correction, the flow rate displayed on the calibrator changes,
the flow rate displayed on the pump does not change. The range of flow correction
is ± 2.5 L/min.

4.

Repeat calibration after sampling to verify flow.

Example: The desired flow rate is 10 L/min.
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Set the pump to 10 L/min. If the calibrator displays 9.7 L/min, click the  button
in Flow Calibrate until the calibrator displays 10 L/min. If the calibrator displays
10.5 L/min, click the  button in Flow Calibrate until the calibrator displays
10 L/min. Repeat calibration after sampling to verify flow.

Comm Checking Buttons
The Comm Checking buttons (Figure 9) turn the communication checking function
on or oﬀ. Comm Checking monitors the interface cable connection between the PC
and the pump. The default value is On. If the interface cable becomes detached, an
error message displays (Figure 10). Reconnect the pump and click on Retry. If the
Oﬀ button is selected in Comm Checking, the pump’s real time information will
not be updated.
If programming more than one pump, turn Comm Checking oﬀ by clicking the
Oﬀ button. Turning Comm Checking oﬀ when programming multiple pumps will
eliminate the error message that displays each time the pump is disconnected.

Figure 9.
Comm Checking Button

Figure 10.
Error Message

When Comm Checking is turned oﬀ, the pump will enter Sleep mode five minutes
after the last interaction between the computer and the pump.
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Temperature Display
The Temperature Display (Figure 11) shows the temperature of the air entering the
connected pump.
Cell
Readout
Min ........................................................minimum air temperature during the
program run
Max........................................................maximum air temperature during the
program run
TWA ......................................................time-weighted average (TWA) of all air
temperatures
Ambient ...............................................current air temperature
Note: The Temperature Display is not ambient
air temperature. It reflects the temperature of
the air within the pump.

Figure 11. Temperature Display

The Min, Max, and TWA are calculated from
the temperatures measured during the total run
time of the pump. Unless reset, the temperature
data will remain in memory and will be included
in future Min, Max, and TWA calculations.
Reset by clicking on the Reset Volume, Temp,
Run Time, and Pressure button in the Pump
Controls section of the Real Time Monitor
(Figure 11A).
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Figure 11A. Reset Volume,
Temp, Run Time, and
Pressure Button
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Pressure Display
The Pressure Display (Figure 12) shows the atmospheric pressure of the air entering
the connected pump.
Cell
Readout
Min ........................................................minimum atmospheric pressure during the
program run
Max........................................................maximum atmospheric pressure during the
program run
TWA ......................................................time-weighted average of all atmospheric
pressure
Ambient ...............................................current atmospheric pressure

Figure 12. Pressure Display

The Min, Max, and TWA are calculated from
the atmospheric pressure measured during the
total run time of the pump. Unless reset, the
pressure data will remain in memory and will
be included in future Min, Max, and TWA
calculations. Reset by clicking on the Reset
Volume, Temp, Run Time, and Pressure button
in the Pump Controls section of the Real Time
Monitor (Figure 11A).

Figure 11A. Reset Volume,
Temp, Run Time, and
Pressure Button

Pump Controls Buttons
The Pump Controls buttons (Figure 13) directly control the
connected pump.
Control
Function
Run ............................................... places the pump in RUN
Hold.............................................. places the pump in HOLD
Figure 13. Pump
Set Flow ....................................... opens the Monitor Set Flow
Controls Buttons
window (similar to Figure 25)
Reset Volume, Temp,
Run Time, and Pressure .....clears the accumulated data: volume, temperature
(Min, Max, and TWA), time, and pressure (Min, Max,
and TWA)
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Units Selection Buttons
The Units Selection buttons (Figure 14) allow the user to select the temperature and
pressure units of the connected pump.
Control
Function
Fahrenheit ....................................selects the Fahrenheit temperature scale
Celsius ..........................................selects the Celsius temperature scale
in-Hg .............................................selects the atmospheric pressure display in units of
inches of mercury
millibar.........................................selects the atmospheric pressure display in units of
millibar
mm-Hg..........................................selects the atmospheric pressure display in units of
millimeters of mercury

Fault Options

Figure 14. Units Selection Buttons

Figure 15. Fault Options

The Fault Options (Figure 15) allows the user to select the time the pump spends in
flow fault mode and the number of times the pump attempts to restart.
Cell/Control
Readout/Function
Time to Fault (sec) ..................click on the box and enter a number from 5 to 30.
This value is the number of seconds the pump spends
in Flow mode before going into Flow Fault Hold
mode.
Number of Retries..................click on the box and enter a number from 0 to 25.
This value is the number of times the pump attempts
to restart once it goes into Flow Fault Hold mode.
Time to Retry (sec) .................click on box and enter a number from 5 to 600. This
value is the number of seconds between when the
pump goes into Hold after a flow fault and when it
restarts.
Set Fault Options....................saves the chosen options
Fault On/Fault Oﬀ ..................enables/disables Fault mode. When set to “Fault Oﬀ,”
no flow fault will occur.
14
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STEL/Timed Run
The STEL/Timed Run window (Figure 16) allows the user to set a pump run for a
predetermined length of time, e.g., 15 minutes. Once the STEL/Timed Run is set,
the user presses the  keys on the pump simultaneously to start the run. After
the timed run is completed, the pump will stop automatically.

Figure 16. STEL/Timed Run Window

STEL/Timed Run
Menus
File Menu
Exit.............................exits the STEL/Timed Run window
Tools Menu
Clear STEL
in Pump .................cancels the programmed sampling time
Change Default
Flow Buttons .........displays a text box reminder on how to change the
default flow rates displayed on the Flow Selection
buttons in the STEL/Timed Run window

STEL/Timed Run Buttons
Control
Function
Flow Selection (L/min) ..............permits selection of pump flow rate
Run Time .....................................permits pump run time to be set in hours and
minutes
To Pump .......................................sends settings to pump
Reset Volume, Run
Time, Temps, Pressures..........resets Min, Max, and TWA values in Real Time
Monitor
To program a sampling time, use the flow selection buttons and scroll bar to select
a flow rate. Enter the duration of the sample run by clicking on the Run Time box
and entering the run time. The sampling time can be set up to 99,999 minutes.
Once the flow rate and sampling time have been set, click the To Pump button to
program the connected pump.
15
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SKC Pump Scheduler
The SKC Pump Scheduler window (Figure 17) is the DataTrac programming
window. Programs can be created, sent to a pump, saved to a PC, loaded from a
disc or a pump, and printed.
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Figure 17. Pump Scheduler Window
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B.
C.
D.
E.
F.
G.
H.
I.

Program Edit Bar (page 17)
Pump Schedule (page 18)
Programming Buttons (pages 18-20)
Set Flow Button (page 20)
Calendar (page 21)
Clock (page 21)
Time Bump all Dates Buttons (page 22)
Repeat Schedule (page 26)
Digital Time Display (page 22)
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Pump Scheduler Menus
File Menu
Open ..............................opens a pump program previously stored on disc
Save ...............................saves a pump program to a PC
Print ...............................prints the pump program schedule displayed on
the screen
Exit.................................exits the Pump Scheduler window
View Menu
Cycle Scheduler ...........opens Cycle Scheduler window
Preview Repeat
Schedule ....................opens Repeat Scheduler window
Scheduler Presets ........opens Scheduler Options window
Clock Resolution .........sets the clock resolution
Tools Menu
Clear Schedule .............clears the programmed pump schedule
Clear History................clears the pump history
Compare Pump
Clock/PC Clock.........opens the time display window and allows
the pump and PC times to be synchronized
(see Figure 3)
Comm Checking ..........Enables/disables communication checking,
indicated by  on menu

Program Edit Bar

Figure 18. Program Edit Bar

The Program Edit Bar (Figure 18) is where the user sets up a pump program. A
program is set up by entering the Flow Rate, Start Date/Time, Stop Date/Time, and
Duration in the cells of the Program Edit Bar.
A pump program contains these sampling parameters:
Parameter
Value
Rate ...........................................flow rate in L/min
Start Date .................................start date of the program
Start Time ................................start time of the program
Stop Date .................................stop date of the program
Stop Time.................................stop time of the program
Duration ...................................total run time of the program in days: hours:
minutes: seconds ([d] h:mm:ss)
To program the above parameters into the cells of the Program Edit Bar, click on
the Programming buttons (see pages 18-20) that select the value of the parameters,
then click on the appropriate cell.
17
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Pump Schedule
The Pump Schedule (Figure 19) contains pump programs (or pump schedules) set
by the Program Edit Bar. The pump is programmed for a sampling operation by
sending this list of programs to the pump‘s memory. The Pump Schedule is built
by using the Programming buttons described in the next section. The maximum
number of programs that can be contained in the Pump Schedule is 26.

Figure 19. Pump Schedule Containing Programs

Before entering a program into the Pump Schedule, go to the Scheduler Options
window (Figure 35) to reset data and pump history.

Programming Buttons
The Programming buttons (Figure 20) select the program parameters, insert
programs into the Pump Schedule, write programs to the pump, and read programs
from the pump.

Figure 20. Programming Buttons

Button
Function
Clr ..........................erases the program in the Program Edit Bar
+Day ......................adds one day to the program in the Program Edit Bar, which is
useful for programming same start and stop times on consecutive
days, or use Repeat Scheduler (see page 26)
Insert .....................places the program displayed in the Program Edit Bar into the
Pump Schedule
Cut .........................clears the selected (highlighted) program in the Pump Schedule
and places it into the Program Edit Bar where it can be edited
FromPump ...........reads the program stored in the pump and displays it in the Pump
Schedule
ToPump ................writes the program displayed in the Pump Schedule to the
pump
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Insert Button
To insert the completed program from the Program Edit Bar into the Pump
Schedule (Figure 19), click on the Insert button (Figure 20). The Pump Schedule can
hold 26 programs. However, if a large number of programs are to be stored, consider
using the Cycle Scheduler (see page 25) or the Repeat Scheduler (see page 26).

Cut Button
To clear the selected (highlighted) program from the Pump Schedule and place it
into the Program Edit Bar, click on the Cut button (Figure 20). A program can also
be cut by double-clicking the program number or the line number to the left of the
rate column of the Pump Schedule (Figure 19).
Clear the history either in the Scheduler Presets menu or in the Tools menu and
set Scheduler Presets in the View menu before sending a program to the pump by
clicking the ToPump button.

ToPump Button
To write the Pump Schedule to the pump, click the ToPump button (Figure 20). A
dialog box will appear (Figure 21).
Click OK in the dialog box to send the program to the
pump. A “Program Loaded” dialog box (Figure 22)
will appear on screen to verify the operation.
An overwrite dialog box will appear if a program
has already been sent to the pump. Click Yes if
you wish to overwrite the program in the pump.
Writing a program to the pump will cause the PROG
icon to appear on the pump LCD (Figure 23), which
will remain active until all programs have run.
The pump cannot be controlled manually until all
programmed schedules have run.

Figure 21. Confirmation
Dialog Box

Figure 22. Program Loaded
Dialog Box

Edit a Program
To edit a program displayed in the Pump Schedule,
double-click on it. This will remove it from the Pump
Schedule and place it in the Program Edit Bar. Any
program already in the Program Edit Bar will be erased.
Click insert once the program is edited to move it back
to the Pump Schedule.
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Figure 23. Leland Legacy
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FromPump Button
To display a Pump Schedule from a previously programmed pump, click on the
FromPump button (Figure 20).

Time Bump Buttons
To increase or decrease all program start and stop times in the Pump Schedule,
click on the Time Bump buttons (Figure 32).

Save a Program (File Menu)
To save information from the Pump Schedule to a PC as a program file, select the
Save command from the File menu.
The default extension “.pgm” is used to indicate Pump Schedule files.

Open Program (File Menu)
To open a previously stored program, select Open from the File menu.

Print Program (File Menu)
To print the Pump Schedule information displayed on the screen, select Print from
the File menu.

Set Flow Button
The Set Flow button (Figure 24) opens the Scheduler Set Flow
window (Figure 25) to allow the user to set the pump flow rate.

Scheduler Set Flow Window
The Scheduler Set Flow window (Figure 25) allows the user to
select the pump flow rate using the numbered flow buttons and
the scroll bar.

Select Flow Rate

Figure 24.
Set Flow
Button

To set the flow rate, click on the desired flow
rate button. The new flow rate appears in the
display cell.

Scroll Bar
To increase or decrease the displayed rate, use
the scroll bar.

Enter Flow Rate
To enter the displayed flow rate into the Rate cell
of the Program Edit Bar, click on OK.

Previous Button
To reset the displayed flow rate to the previously
set pump flow rate, click on the Previous button
in the Scheduler Set Flow window.
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Figure 25.
Scheduler Set Flow Window
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Calendar
The Calendar (Figure 26) shows the time interval
over which the pump can be programmed. Use the
Calendar to select the start and stop dates for the
scheduled sample run.

Selecting a Date
To select a date, click on it then click on the Start
Date/Time or Stop Date/Time cell in the Program
Edit Bar to enter the date into that cell. Use the right
and left arrows to select a diﬀerent month.

Figure 26. Calendar

Clock
The Clock (Figure 27) consists of a clock face, a digital
display corresponding to the time on the clock face,
AM and PM buttons, and the current date and time. The
clock face perimeter is divided into 10, 15, and 30-minute
and 1-hour intervals depending on the selected clock
resolution (Figure 28).

Figure 27. Clock

Clock Resolution
To change the Clock Resolution or time
intervals to 10, 15, or 30 minutes or 1 hour,
select the Clock Resolution command from
the View menu (Figure 28). Clock Resolution
can also be selected by clicking on the clock
face perimeter between the digits.

Figure 28. Clock Resolution

Selecting Time Using the Clock Face
To select the start or stop times, select the Clock
Resolution (Figure 28), click on the clock face
perimeter, the AM or PM button, and then click
on the Start Date/Time or Stop Date/Time cell of
the Program Edit Bar.
Example: To set the time to 4:15 PM, select
“15 minutes” from the Clock Resolution menu
(Figure 28), click on the clock perimeter at 4:15
(Figure 29), and click on the PM button.
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Figure 29.
Select 4:15
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Selecting a Time Using the Digital Time Display
The Digital Time display (Figure 30) can also be used to select
the time, especially outside the clock resolution settings. Doubleclick on the time display to highlight it (Figure 31), then key in
the desired time (including the colon). One or more
numbers can be individually selected by clicking and
dragging across the digit to be changed. Click on the
appropriate time cell in the Program Edit Bar to enter
the time into that cell.

Figure 30.
Digital Time
Display

Figure 31.
Select Time
Display

Time Bump all Dates Buttons
The Time Bump all Dates buttons (Figure 32) add or subtract the
selected time interval to all program Start Time and Stop Time in
the Pump Schedule.

Time Interval
Click on the desired time interval.

Minus (-) Button
To subtract the selected time interval from all
programming steps, click on the (-) button.

Plus (+) Button
To add the selected time interval to all programming
steps, click on the (+) button.
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Figure 32.
Time Bump all
Dates Buttons
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Date/Time Display

FLOW

To access the Date/Time Display window (Figure 33), go to the Tools menu and
select Compare Pump Clock/PC Clock. This feature allows the time and date of
the PC and the connected pump to be synchronized.

L / mins

LelandLegacy

Figure 33. Date/Time Display Window

Resetting the pump time will issue a Clear History Message (Figure 34). The
pump history must be cleared before the pump time can be reset.

Figure 34. Clear History Message
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Scheduler Options
To access the Scheduler Options window (Figure 35) in the SKC Pump Scheduler,
go to the View menu and select Scheduler Presets. The Scheduler Options window
includes User Lock Out, Clear History, and Reset Volume, Time, Temperatures, and
Pressures. The Scheduler Options take eﬀect when the Pump Schedule is sent to the
pump’s memory from the SKC Pump Scheduler window (see page 16).

Figure 35. Scheduler Options

Button

Function

User Lock Out .....................click on the box to activate (a check mark will appear)
or click again to remove check mark and deactivate;
User Lock Out will prevent anyone from altering the
pump operating parameters once a schedule has been
sent to the pump. However, the operator will still be
able to scroll through the data display. Select “Unlock
Pump After Schedule has Completed” for automatic
deactivation or choose “Keep Pump Locked...” for
continued security (unlock in DataTrac).
Reset Volume, Time,
Temps, Pressures .............click on Yes to activate or No to deactivate; Yes will
reset the accumulated volume pumped, time duration,
minimum and maximum temperatures, and pressure
data to zero (0).
Clear History .......................click on Yes to activate or No to deactivate
To set the values and return to the previous window, click the OK button.
All activated options will take effect when the ToPump button (Figure 20)
is clicked. The ToPump button sends the information in the Pump Schedule
(Figure 19) to the connected pump.
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Cycle Scheduler
To access the Cycle Scheduler window (Figure 36) in the Pump Scheduler, go to the
View menu and select Cycle Scheduler. The Cycle Scheduler window allows the
user to program intermittent (repeated start/stop) sampling cycles that will run over
several days in a minimal number of steps. See pages 27-30 for an example schedule.

Figure 36. Cycle Scheduler

Cell/Button
Readout/Function
Cycle Setup Run Cell ........enter time that each cycle is to run
Cycle Setup Hold Cell .......enter time between each cycle
Seconds, Minutes,
Hours Buttons ..................select time increment for Run and Hold
Flow Rate Cell .....................enter pump flow rate in L/min
Start Date, Time Cell .........enter starting date and time of first cycle
Number of Cycles Cell ......enter total number of cycles to run
Cycle-Scheduler
Times .................................DataTrac automatically compiles the cycle schedule
based on the user input and summarizes it in this cell.
Total Run Time and Total Volume are also calculated
and displayed
Duty-Cycle Visualizer .......bar graph indicates how much of the time the pump
will be running
Send Schedule to
Pump Button ....................sends the cycle program to the attached pump
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Repeat Scheduler
To activate the Repeat Scheduler (Figure 37), go to the Repeat Schedule cell in the
Pump Scheduler window and click in the box until a check mark appears. Click on
the desired time frame (daily or weekly) and enter the desired number of cycles in
the Execute Count cell. Enter the desired flow rate in the Set Flow cell or click the
Set Flow button. Click the ToPump button. Go to the View menu and select Preview
Repeat Scheduler. A summary including total run time and volume will appear. The
Repeat Scheduler allows the user to repeat a pump schedule over many weeks. The
schedule can vary from day to day. See pages 27-30 for an example schedule.
There must be a Pump Schedule in place to take advantage of this feature.

Figure 37. Repeat Scheduler

Cell/Button
Readout/Function
Repeat Schedule Cell ..........click to activate the Repeat Scheduler (check mark)
Daily/Weekly Buttons .........click desired repeat interval
Execute Count Cell ...............enter number of intervals schedule is to repeat
Set Flow Cell and Button ....enter or select pump flow rate in L/min
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Example Scheduler Program
This example program demonstrates step-by-step how to use the SKC Pump
Scheduler window (see page 16) to set a program.
A sampling operation requires the Leland Legacy to sample at a constant flow of
10 L/min from 8:00 AM to 4:00 PM daily for one work week. Enter the parameters
as follows.

To Reset Volume, Time, Temperature, and Pump History
To set the flow rate:
Click on the Set Flow button. The Scheduler Set
Flow window opens. Click on the 10.0 button
then click on OK. “10.0” now appears in the Rate
cell of the Program Edit Bar.

To set the start/stop date:
Click on any Monday in the Calendar (do not select a date
already past). The date is now highlighted. Click on the
Start Date/Time cell in the Program Edit Bar. The date now
appears in the cell. Click on the Stop Date/Time cell to enter
the same date into the Stop Date cell.

To set the start time:
Click on the Clock at 8. The clock hands will now point
to 8:00 and it also appears in the digital display next to
the Clock. Click on the AM button, then click on the Start
Date Time cell of the Program Edit Bar; 8:00 AM now
appears in the cell.
Click here

To set the stop time:
Click on the Clock at 4. The clock hands will now point
at 4:00 and it also appears in the digital display next to
the Clock. Click on the PM button, then click on the Stop
Time cell of the Program Edit Bar; 4:00 PM now appears
in the cell. The Duration cell now displays 8 hours, which
is the length of the programmed operation.

Click here
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To insert the program into the Pump Scheduler:
Click on the Insert button. The program appears in the Pump Schedule.
Note that the program is still displayed in the Program Edit Bar. The
Pump Scheduler now has a program that tells the pump to run at a
constant flow of 10 L/min from 8:00 AM to 4:00 PM on Monday. The
same operating parameters must be entered for each day of the week.

To add extra days to the program schedule:
Click on the +Day button. This will add one day to the Start Date and
Stop Date in the Program Edit Bar. Click on Insert to place the program
into the Pump Scheduler.
Repeat the procedure to add an additional day to the Pump Scheduler
until each day of the week has been entered.
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Repeat Scheduler
If the user wishes to repeat the example schedule for the next 10 weeks, the Repeat
Scheduler could be used to save entry time (refer to Figure 37).
1.

In the Pump Scheduler, set up a regular program (see pages 16-24).

2.

At the bottom of the window, click on the Repeat Schedule box (a check mark
should appear).

3.

Click on the Weekly button.

4.

Click in the Execute Count box and enter the number 10.

5.

Click on the ToPump button to send the program to the pump.

Cycle Scheduler
To set up the same scenario in the Cycle Scheduler, follow this procedure (refer to
Figure 36):
1.

In the SKC Pump Scheduler, go to the View menu. Select Cycle Scheduler.

2.

Go to the Start Date, Time section and select the start date of Mar 17. Click in
the Time box. Use the  keys to select 8:00 AM or highlight the digit to be
changed, and type in the desired number.

3.

Move to the Number of Cycles box, highlight the current entry, and type
in 5.

4.

Go to the Cycle Setup section. Click in the Run box and highlight the current
entry. Type in 8. Click in the Hold box, highlight the current entry, and type in
16 (time between runs). Choose hours as the unit of time.

5.

Go to the Flow Rate section and click on the Change Flow button. Select a flow
rate of 10 L/min and click OK.

6.

Verify that the schedule is correct by reviewing the Cycle-Scheduler Times
window. The horizontal Duty-Cycle Visualizer bar graph at the bottom of the
window can be used as a visual cue as to how much of the time the pump will
be running.

7.

Once the schedule is verified, click on the Send Schedule to Pump button.
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To set the desired Scheduler Options:
Select Scheduler Presets from the View menu and click on the desired
Scheduler Options (see page 24).

To write the program to the Pump:
Click on the ToPump button. DataTrac will now write all steps contained
in the Pump Schedule to the pump.

To save a pump program to a PC:
Select the Save command from the File menu. The program displayed
in the Pump Schedule will be saved as a program file (.pgm). Programs
can be saved for future use or editing.

To print the pump program:
Select the Print command from the File menu; this prints the contents of the Pump
Schedule.

To erase the contents of the Pump Schedule:
Select Clear Schedule from the Tools menu; this will erase the contents of the Pump
Schedule displayed on screen and in the connected pump‘s memory.
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SKC Pump History
The SKC Pump History window (Figure 38) displays a record of all operations the
pump has performed. Approximately 300 histories can be stored in the pump‘s
memory. This window can also be saved to a PC or printed.

Figure 38. SKC Pump History Window

SKC Pump History Menus
File Menu
Print History ................prints the current history
Save History .................saves a history file to a PC. Can be viewed using
Archive History (see page 34)
Save as Commaseparated Text ...........saves history file as a text file (.txt)
Exit ................................exits the SKC Pump History window and
returns to the previous screen

Tools Menu

Clear History................clears the pump history displayed on screen
and in pump memory
Options .........................provides history display and sample interval
options
Reload History .............reloads existing history
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Clear Pump History
To clear the pump history, select Clear History from the Tools menu.

Change Options*
To change display and sample interval pump history options, select Options from
the Tools menu.
* Changes to these parameters will also be reflected on the pump LCD.

Reload History
To reload existing pump history, select Reload History from the Tools menu.

Print Pump History
To print the pump history file displayed on screen, select Print from the File menu
(see page 31).

Save Pump History
To save a pump history to a PC, select Save from the File menu. The pump history
is saved to a PC as a history file (.hst).

Save Pump History as Comma-separated Text
To save a history file as a text file (.txt), select Save as Comma-separated Text from
the File menu.

Pump History Display
Data displayed in the Pump History window (Figure 38) shows the record or history
of all operations performed by the pump. A history will remain on screen and in
pump memory until it is cleared. If more than 300 history operations have occurred
since history was cleared, they will roll over in memory so that the 300 most recent
operations will be displayed. A history includes the following data:
Pump Status Mode
Readout
Operating State of the Pump
Run ........................pump in run mode
Hold ......................pump in hold mode
Fault (Run) ...........pump in flow fault status while running
Fault (Hold)..........pump in flow fault status and hold mode
Prog (Hold) ..........pump in hold mode while running a program
Prog (Run) ............pump in flow mode while running a program
Prog (Sleep) ..........pump in sleep mode while running a program
Reset ......................run time data has been zeroed
Sleep ......................pump in sleep mode
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User Setup ............pump user interface accessed and user adjusting
pump
Pre-Cal Flow ........single-point calibration mode; first calibration
average, date, and time
Post-Cal Flow .......single-point calibration mode; final calibration
average, date, and time
Timed Run............pump running a preset sampling time (ST)
Low Bat .................battery depleted
FullCal...................full (multiple-point) calibration mode
Flow Adjust ..........pump flow rate or flow correction being adjusted by
user
Flow.......................flow rate in L/min
Start Date ..............start date of the program
Start Time .............start time of the program
Volume (Liters) ....flow rate multiplied by the duration
Accum. Volume ...sum of all previous volumes (Liters) on the history
page
Duration ...............total running time of the program
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Archive History
The Archive History window loads and displays a pump history file that was saved
to a PC. This window is empty until a history file is opened.

Archive History Menus
File Menu
Open ..............................opens a saved history file
Print ...............................prints the displayed history file
Exit.................................returns to the previous window

Open a History
To open a history file, select Open from the File menu. Browse to and select the
desired “.hst” file.

Print a History File
To print a history file, select Print from the File menu.
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Reports
DataTrac allows reports or worker exposure profiles to be printed or saved as text
and imported into word processing software or a text editor. These files combine
the setup data (information denoting sampling media, methods, location, etc.) from
the Sample Sheet Setup window (Figure 39) and a pump history (Figure 38).
File menu
Open ......................opens a saved report file
Save as Text ..........saves report as text (.txt) that any word processor or
text editor can read
Print .......................prints the displayed worker exposure profile
Exit.........................exits the worker exposure profile

Sample Sheet Setup
The Sample Sheet Setup window (Figure 39) saves setup data pertaining to the
sample run. All data displayed on the screen can be printed or saved as a setup file
(.stp), or user-selected data can be saved as a template file (.tpl).

Figure 39. Sample Sheet Setup Window

Sample Setup Menus
File menu
New .......................clears all data cells in the Sample Sheet Setup window
Load Setup ...........loads a setup file
Save Setup ............saves a setup file
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Load Template .....loads a template file
Save Template ......saves a template file
Print .......................prints the current sample sheet data displayed on screen
Exit.........................exits the Sample Sheet Setup window and returns to the
previous window
Option Menu
Merge Pump ........writes the pump history from the connected pump
memory to the displayed sample sheet setup and creates
a worker exposure profile
Merge File.............writes the pump history from a previously stored
history file to the displayed sample sheet setup, and
creates a worker exposure profile
Clear Sample
Sheet ...................clears all entered data from cells

Setup Files
The Sample Sheet Setup window (Figure 39) contains a list of information (in data
cells) that will be printed in a report. The displayed sample sheet setup can be saved
to a PC as a setup file (.stp). A setup file consists of all the information contained
in all data cells.

Enter Data into Sample Sheet
To enter the information into the data cells, click on the cell then type the data
using a keyboard. The Tab key can be used to move from one cell to the next.

Save Setup
To save all entered data, select the Save Setup command from the File menu.
The Save Setup command saves all data as a setup file (.stp).

Template Files
The displayed sample sheet setup can also be saved to a PC as a template file (.tpl).
A template file reduces the need to repeatedly type data that rarely changes. A
template file contains only the information included in the data cells that have an
active check box (the small square button before the data cell as shown in Figure
40). To activate a check box, click on it until a check mark appears.

Figure 40. Close-up of the Sample Sheet
Setup Window Showing Active Check Boxes
36

Reports
Save Template
To save only the information contained in data cells with active check boxes, select
Save Template from the File menu. The Save Template command saves the checked
data as a template file (.tpl).

Print
To print the displayed sample setup or template, select Print from the File menu.

Worker Exposure Profile
A worker exposure profile contains a sample sheet setup file and a pump history.
A worker exposure profile can be created using the connected pump’s history or a
history file (.hst) saved to a PC.
Worker Exposure Profile created with Pump History
To create a worker exposure profile containing the sample sheet displayed on screen
and the history of the connected pump, select Merge Pump from the Options menu
of the sample sheet. The worker exposure profile will be saved to a PC as an “.rpt”
file and will also appear on screen.
Worker Exposure Profile created with History File
To create a worker exposure profile containing the sample sheet displayed on screen
and a history file saved to a PC, select Merge File from the Options menu. The
worker exposure profile will be saved to a PC as an “.rpt” file and will appear on
screen.

Print Worker Exposure Profile
To print the worker exposure profile displayed on screen, select Print from the File
menu.
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CalChek Full Calibration Data Display and Verification

Figure 41.
Calibration Info Window

Viewing CalChek Full Calibration Data
Caution: Full calibration completely clears DataTrac, run time parameters, and
the Pump Schedule.
Full calibration data can be viewed and printed by going to the DataTrac Pump
Manager window and clicking on the View menu. Choose Calibration Info (Figure
41). This window will display calibration results, pump serial number, and date of
the last full calibration.

Calibration Info Window
The Calibration Info window displays the results of a full calibration after using
CalChek, allows data to be printed, and provides a means of validating printed data.

File Menu
Print .......................prints the current calibration data
Exit.........................exits the Calibration Info window and returns to the
Pump Manager window
Tools Menu
Confirm Validation
Code ...................allows the user to enter calibration data from a printed
report to determine if printed information has been
tampered with
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Validating CalChek Full Calibration Data
To confirm printed calibration data, open the DataTrac Pump Manager window
and click on the View menu. Choose Calibration Info (Figure 41). Click the Print
Report button. Go to the Tools menu and choose Confirm Validation Code (Figure
42). Enter the calibration date shown on the printed report, enter each actual flow,
and then enter the validation code. Click on the Check Validation Code button.
The box to the right of the button will display red and “invalid” if the data has
been entered incorrectly or tampered with. A green bar with the word “valid” will
display if data entered is valid.

Figure 42.
Calibration Info Window with Confirm Validation Code

Clearing the history will not clear full calibration data. This data can only be
cleared by performing another full calibration.
When entering data to confirm the validation number, enter the date in the
following format: mmm dd, yyyy (e.g., Aug 18, 2010).
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